K-IDE support forum
Find all information about Kawasaki's Integrated Development Environment

KIDE shut down

#1 by Robotiker ( deleted ) , Fri Feb 14, 2020 2:43 pm

Hej,

we have a Problem on one PC by trying to connect KIDE to a Controller.
KIDE in the newest Version (32BIT). Win 10 Pro.

We can open KIDE and work with it. But if we want to connect to the Controller (E02) KIDE shut down kompletely.

Kind Regards

Robotiker


Robotiker

RE: KIDE shut down

#2 by cquante , Thu Feb 20, 2020 7:23 am

Hello Roboticer,

welcome to the forum and thank you for your report!

Is there any message before the shut down of KIDE?

The 32 bit version of KIDE is very rarely used (I guess). It's converted from 64 bit version by hand just before any release. But I test each 32 bit version on an old Win 7 32 bit notebook. Maybe I missed something. Please give me some time to test again.

BTW... is there any reason to use a 32 bit version for Win 10?


Christian Quante
Project Support & Development
Technical Department

Kawasaki Robotics GmbH
Rheiner Landstrasse 195A • 49078 Osnabrück
Germany


 
cquante
Posts: 281
Date registered 12.20.2019


RE: KIDE shut down

#3 by cquante , Thu Feb 20, 2020 9:49 am

I just tested KIDE on my old notebook using Win 7 32 bit and KIDE 32 bit. I connected successfully to an E01 controller.

Is .NET installed on your Win10 machine? Can you please take a look at the program information window? Will it crash too?


Christian Quante
Project Support & Development
Technical Department

Kawasaki Robotics GmbH
Rheiner Landstrasse 195A • 49078 Osnabrück
Germany


 
cquante
Posts: 281
Date registered 12.20.2019


RE: KIDE shut down

#4 by RobLab DF MGTU , Thu Jan 21, 2021 11:14 am

Hello.

I'd like to up this thread.
I have the same problem. When I try to conect to any robot, KIDE close immidiatly without any message. It happenes even if I try to connect to socket without any real unit or to unplugged robot.
My system: win10pro x64 and KIDE 1.0.0.0 x64.

I also want to add, when I asked the programm info from menu (help->program info) I got the error message about an absence of krcc64.dll (I attach the picture). After that I saw program information window without any loaded used librares (I attach the picture).
At my another computer with win10home x64 and KIDE 1.0.0.0 x64 I can connect to robots and I can see the next used librares: krcc64, FastColoredTextBox and IpAddressControlLib.
I checked existence of those dlls. At both my problem and my problem-free computers those libraries files lies byside KIDE exe-file.
I hope the information will help to fix that problem.

Best regards, Vladimir.

Attached pictures:
About.PNG   Error.PNG  

RobLab DF MGTU  
RobLab DF MGTU
Posts: 3
Date registered 01.21.2021


RE: KIDE shut down

#5 by cquante , Fri Jan 22, 2021 7:24 am

Dear Vladimir,

thank you for your report!

It seems that Windows cannot access KRCC64.dll on your computer. "Cannot load..." does not mean that the file does not exist but also that the file may be blocked.

Can you please check the file settings of your DLLs? If there's an entry just like the following picture (sorry it's in German), please select the checkbox and press the OK button.



I hope this will help.


Christian Quante
Project Support & Development
Technical Department

Kawasaki Robotics GmbH
Rheiner Landstrasse 195A • 49078 Osnabrück
Germany


 
cquante
Posts: 281
Date registered 12.20.2019


RE: KIDE shut down

#6 by RobLab DF MGTU , Fri Jan 22, 2021 1:29 pm

Dear Christian,
any my playing with security attributes were useless.

But I was be able to fix my problem.
At first I checked dependencies of dlls. I had started Dependency Walker tool (I haven't permission to post external links) and found a problem of krcc64.dll. It wanted msvcp100.dll and msvcr100.dll, but they weren't at my problem computer (I note that the dotNET had been installed with MS Visual Studio 2019). Then I found those libraries at my computer with wellworked KIDE and put them into my problem KIDE directory (it's a very bad dicision, I only tested a problem).
Voila, I could connect KIDE and robot.
A right way of fixing will be use Microsoft Visual C++ 2010 Redistributable Package. It contains the required libraries.

Best regards, Vladimir.



The following user say thank you: cquante
RobLab DF MGTU  
RobLab DF MGTU
Posts: 3
Date registered 01.21.2021

Last edited 01.22.2021 | Top

RE: KIDE shut down

#7 by cquante , Mon Jan 25, 2021 10:00 am

Dear Vladimir,

thank you for the information!

Zitat von RobLab DF MGTU im Beitrag #6
A right way of fixing will be use Microsoft Visual C++ 2010 Redistributable Package. It contains the required libraries.



I will put the library into the installation script in the next version.


Kind regards,
Christian


Christian Quante
Project Support & Development
Technical Department

Kawasaki Robotics GmbH
Rheiner Landstrasse 195A • 49078 Osnabrück
Germany


The following user say thank you: correlation180
 
cquante
Posts: 281
Date registered 12.20.2019


RE: KIDE shut down

#8 by RobLab DF MGTU , Tue Jan 26, 2021 8:29 am

Dear Christian,

I'm glad I could be of help. :)

Best regards,
Vladimir.


RobLab DF MGTU  
RobLab DF MGTU
Posts: 3
Date registered 01.21.2021


   

Colors limited to 15
Port-Problems



Xobor Xobor Community Software
Datenschutz