K-IDE support forum
Find all information about Kawasaki's Integrated Development Environment

Error Comment___ (); When uploading program to robot

#1 by Mariangelo , Wed Jul 26, 2023 12:26 pm

The following error occurs when I try to upload this simple program to the robot:



Mariangelo  
Mariangelo
Posts: 8
Date registered 07.26.2023

Last edited 07.26.2023 | Top

RE: Error Comment___ (); When uploading program to robot

#2 by cquante , Wed Jul 26, 2023 12:43 pm

Hello,

can you be more specific? What is the controller type and what data are you uploading? I can see that you also upload a Main program.

Zitat von Mariangelo im Beitrag #1
The following error occurs when I try to upload this simple program to the robot:



The error must not be in the comments___ program. As it is the last entry in the list of transferred data, the error message is right below the messages with the program list. Maybe there's a specific error message some lines above?


Christian Quante
Technical Sales
Sales Department

Kawasaki Robotics GmbH
Rheiner Landstrasse 195A • 49078 Osnabrück
Germany


 
cquante
Posts: 281
Date registered 12.20.2019


RE: Error Comment___ (); When uploading program to robot

#3 by Mariangelo , Wed Jul 26, 2023 1:55 pm

Thanks for replying so quickly,

the controller i'm using in my K-ROSET project is a MX500N and i'm loading all the system data. I haven't set up any controller in my KIDE program yet, in fact the Robot/controller tab is empty. You were right about the error, in fact this is the error:



This error occurs only when I load all system data and not when I load only the AS file comment.

I'm sorry to bother you about such silly errors, I'm using this robots for the first time for the company I work for.

Mariangelo


Mariangelo  
Mariangelo
Posts: 8
Date registered 07.26.2023


RE: Error Comment___ (); When uploading program to robot

#4 by cquante , Wed Jul 26, 2023 3:07 pm

It seams to be an incompatibility between the data you send and the K-Roset's controller firmware for MX500 regarding the line "ACCUR ..." in the AUX section. Maybe your backup data does not contain as many ACCUR parameters as the firmware version in K-Roset expects. The message states that there's an error in parameter 5 so maybe you only got 4 parameters in that line?


Christian Quante
Technical Sales
Sales Department

Kawasaki Robotics GmbH
Rheiner Landstrasse 195A • 49078 Osnabrück
Germany


The following user say thank you: Mariangelo
 
cquante
Posts: 281
Date registered 12.20.2019


   

copy/cut/paste in interface panel doesn't work
INRANGE return value



Xobor Xobor Community Software
Datenschutz