K-IDE support forum
Find all information about Kawasaki's Integrated Development Environment

copy/cut/paste in interface panel doesn't work

#1 by TRapp , Tue Nov 07, 2023 8:26 am

1. I used the original (clean) AS download from the controller.
2. created a MONITOR command button to move the robot
3. used cut/copy/paste do multiply those buttons
4. edited all the buttons with the functions I needed
5. saved the file
6. opend the file again - most edits are gone

I attached the file:
ON page2 I had 6*4 buttons for the motions X/Y/Z/RX/RY/RZ in +/- direction and two increments configured.
But after close/open the file only a few buttons were left ... most of my copy/pasted/edited buttons are gone.

The file only shows that there are only few buttons on page 2 - but I guess it should be possible to replicate that problem.

EDIT:
originally I thought it's only a problem with cut/copy/paste
... but now I think the problem could be also the length of the monitor command.
the fields with longer monitor commands are in the AS file but don't show up in KIDE

regards from Taiwan


Attachment:
test1.txt

TRapp  
TRapp
Posts: 18
Date registered 06.24.2023

Last edited 11.07.2023 | Top

RE: copy/cut/paste in interface panel doesn't work

#2 by TRapp , Tue Nov 07, 2023 9:13 am

after more testing I pulled another backup from the controller and found that the Interface is completely messed up.

So another idea is that Commas in monitor commands don't work ...

Attachment:
original_test2.txt test2.txt

TRapp  
TRapp
Posts: 18
Date registered 06.24.2023


RE: copy/cut/paste in interface panel doesn't work

#3 by TRapp , Tue Nov 07, 2023 10:52 am

OK - Sorry my mistake ... I didn't set the command number - looks like there are only 20 monitor commands which can be stored

So I checked again - and monitor commands with commas as well as longer monitor commands are working.

For example "DO DRAW 0,0,0,0,0,-0.5"

But still leaves the question, why buttons disappeared in K-IDE ... ?


TRapp  
TRapp
Posts: 18
Date registered 06.24.2023


RE: copy/cut/paste in interface panel doesn't work

#4 by cquante , Wed Nov 08, 2023 3:19 pm

Dear @TRapp ,

thank you for your report!

I checked your data and found an error in the IFP parser. The problem is the comma separated list of parameters in the monitor command fields.


Christian Quante
Technical Sales
Sales Department

Kawasaki Robotics GmbH
Rheiner Landstrasse 195A • 49078 Osnabrück
Germany


The following user say thank you: Taiwantobi
 
cquante
Posts: 281
Date registered 12.20.2019


   

empty interface panel is not sent
Error Comment___ (); When uploading program to robot



Xobor Xobor Community Software
Datenschutz