K-IDE support forum
Find all information about Kawasaki's Integrated Development Environment

Kide is closing while connecting to the robot

#1 by Kapi , Mon Jun 14, 2021 4:55 pm

Hi

One of the users encontered a problem .
When launching KIDE and connecting to the robot KIDE closes automaticly.
When using KCWin connection is established in a proper way.

To make things more complicated PC that is connected to the robot is in USA . It is CX210 with US spec E0x controller.
user is connecting to US PC remotely via VNC.

Any hints or further infomation needed?


Kapi  
Kapi
Posts: 4
Date registered 06.14.2021


RE: Kide is closing while connecting to the robot

#2 by cquante , Mon Jun 14, 2021 5:44 pm

Dear Kapi,

thank you for the report!

It's hard to find out what went wrong without any more details. If K-IDE crashes while connecting I suspect there's a locked krcc64.dll. You can check this by taking a look at the properties of that file in Windows explorer.

If there's a error message popping up, it would be good to know the error details.


Christian Quante
Technical Sales
Sales Department

Kawasaki Robotics GmbH
Rheiner Landstrasse 195A • 49078 Osnabrück
Germany


 
cquante
Posts: 283
Date registered 12.20.2019


RE: Kide is closing while connecting to the robot

#3 by Wojciech Bryczek , Tue Jun 15, 2021 2:09 pm

When we try to open Help in KIDE installed on US PC, an error ocured. You can see it on attatched file "error1.jpg". Also when we click "ok" to confirm , a program info window is empty. You can see that on file "program_info.jpg"


Wojciech Bryczek  
Wojciech Bryczek
Posts: 1
Date registered 06.15.2021


RE: Kide is closing while connecting to the robot

#4 by Kapi , Wed Jun 16, 2021 11:17 am

Mentioned Errors are here

Attached pictures:
err1.jpg   err2.png  

Kapi  
Kapi
Posts: 4
Date registered 06.14.2021


RE: Kide is closing while connecting to the robot

#5 by Kapi , Wed Jun 16, 2021 4:16 pm

Case is solved

C++ libraries were missing on the PC


The following users say thank you: cquante and Seth
Kapi  
Kapi
Posts: 4
Date registered 06.14.2021


RE: Kide is closing while connecting to the robot

#6 by cquante , Fri Jun 25, 2021 8:56 am

That's a good point! You need the vcredist installation files in order to run KRCC correctly. KRoset installation also installs that libraries so the libs are always installed on my PC and I didn't realized any issues.

I will include the vcredist installers in the next release setup.


Christian Quante
Technical Sales
Sales Department

Kawasaki Robotics GmbH
Rheiner Landstrasse 195A • 49078 Osnabrück
Germany

Attachment:
vcredist_32_64.zip

The following user say thank you: Seth
 
cquante
Posts: 283
Date registered 12.20.2019


   

KIDE error uploading a backup to K-ROSET
Buttons of a Project comment



Xobor Xobor Community Software
Datenschutz